FC2ブログ
XPでのunityの動作
2017年04月30日


unityでビルドした実行ファイルがXPで画像の表示が壊れる現象が解決できず3日も浪費してしまったので、こんなことで悩んでいる人が他にいるのか知りませんが、とりあえず書いておきます(´・ω・`)
最新unityはデフォルトシェーダーのバージョンを内部で指定していないと自動的に最新バージョンを読み込んでビルドするらしく、普通にやるとXP等で表示が壊れるようです。なのでシェーダー内部でtarget2.0と書くだけで動くようになります(多分) その代わり最新のシェーダー関数とかは使えなくなります(´・ω・`)




ちんちん




ホーム